Registration Issues

Incident Report for Status Updates | ZeroBounce

Resolved

Captcha services are working again.
Posted Jun 12, 2025 - 12:37 PDT

Investigating

Due to a Cloudflare outage related to captcha services our registration page is not currently working as intended.
Posted Jun 12, 2025 - 12:03 PDT
This incident affected: Website Members Section.