General email delay for certain types of emails during May 24 8.31 PM and May 25 2.25 PM (PST)
Incident Report for Status Updates | ZeroBounce
Resolved
Incident Period: May 24, 8:31 PM to May 25, 2:25 PM (PST)

Issue: During the specified period, there was a delay in the delivery of certain emails, including team account invitations and some two-factor authentication (2FA) emails.

Resolution: The issue was fully resolved on May 25 at 2:26 PM (PST).
Posted May 24, 2024 - 19:00 PDT