Paypal payment issues
Incident Report for Status Updates | ZeroBounce
Resolved
Our team has removed the option for PayPal payments. We will provide updates in the near future.
Posted Apr 07, 2022 - 08:42 PDT
Investigating
We are currently experiencing issues with our Paypal payment platform. Users are advise to process payments through all other alternative methods. The issue is under investigation and we will remediate the problem as soon as possible.
Posted Apr 07, 2022 - 06:05 PDT
This incident affected: Website Members Section.